m1gin 211

UBUNTU ‘da Kullandığım Başlıca Progamlar (mbirgin)

Primary

sudo apt install audacity vlc apache2 inkscape geany chromium-browser scite bleachbit baobab mono-apache-server4 libapache2-mod-mono gpodder audacious sqlite3 sqlitebrowser gparted openjdk-8-jre sox libsox-fmt-all curl openssh-server gpicview sshfs mumble mumble-server mono-xsp4 mono-vbnc xvnc4viewer ffmpeg pcmanfm parcellite mplayer libxml2-utils breeze speedcrunch mpv oathtool xclip yad zenity mediainfo bless unrar lximage-qt easystroke carla calf-plugins lsp-plugins-lv2 wmctrl sxiv recode jq xdotool xautomation xbindkeys xbindkeys-config id3v2 gnome-subtitles aegisub onboard wine espeak gromit-mpx engrampa xfce4-cpugraph-plugin xfce4-notes-plugin xfce4-screenshooter xfce4-taskmanager xfce4-whiskermenu-plugin xfce4-xkb-plugin xfpanel-switch vlc-plugin-access-extra


May Need Interaction:

jackd qjackctl pulseaudio-module-jack ardour

Secondary

qbittorrent virtualbox gimp uget filezilla rdesktop puddletag guvcview smplayer lftp usb-creator-gtk lmms picard

kdenlive flashplugin-installer tuxguitar tuxguitar-alsa tuxguitar-jsa tuxguitar-oss rakarrack unison-gtk lingot hydrogen

No More

xfce4-time-out-plugin vlc-plugin-pulse alarm-clock gksu mplayer2 subliminal

Ambigious

gsfonts-x11

Testing

Might need kxstudio repository

sudo apt install dpf-plugins dragonfly-reverb guitarix ir.lv2 noise-repellent

  • workrave
  • rsibreak
  • safeeyes


Manually Installed:

Google Chrome

  1. wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
  2. sudo dpkg -i google-chrome-stable_current_amd64.deb
  3. rm google-chrome-stable_current_amd64.deb

youtube-dl

  1. sudo curl -L https://yt-dl.org/downloads/latest/youtube-dl -o /usr/local/bin/youtube-dl
  2. sudo chmod a+rx /usr/local/bin/youtube-dl

monodevelop

Ubuntu 18.04

  1. sudo apt -y install apt-transport-https dirmngr
  2. sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
  3. echo "deb https://download.mono-project.com/repo/ubuntu vs-bionic main" | sudo tee /etc/apt/sources.list.d/mono-official-vs.list
  4. sudo apt update
  5. sudo apt install monodevelop

VS Code

  1. sudo apt -y install software-properties-common apt-transport-https wget
  2. wget -q https://packages.microsoft.com/keys/microsoft.asc -O- | sudo apt-key add -
  3. sudo add-apt-repository "deb [arch=amd64] https://packages.microsoft.com/repos/vscode stable main"
  4. sudo apt update
  5. sudo apt install code

Extra Applications

  • mysql-server
  • mysql-workbench
  • jdownloader
  • easytag (mp3 tag editor)
  • Silverlight plugin
  • avidemux
  • clipit
  • picard - detect mp3 songs and get id3 tag information from internet
  • unity3d by pipelight
  • qdirstats - Folders size..
  • blender
  • google-drive-ocamlfuse - mount google drive

Derlenerek yedeklenen bazı paketler...

  1. Thunar 1.6


MonoDevelop

MonoDevelop v7 with flatpak

  • sudo apt install flatpak
  • $ flatpak install --from https://download.mono-project.com/repo/monodevelop.flatpakref
  • $ flatpak run com.xamarin.MonoDevelop


monodevelop 5.5 by hacking:

Get Vivid build of MonoDevelop5.5 then add Utopic repository and fix missing depencies.


monodevelop mono-xsp4 libmono-microsoft-visualbasic11.0-cil

Fix error: "the asp.net add-in is not istalled"

https://stackoverflow.com/questions/36101232/asp-net-template-not-found-after-installed-monodevelop-ide-on-ubuntu-16-04

2018-05: Eski versiyon Mono kurulumu:

Mono 5.10 ile nedense derlenmiş VB projeleri sorun çıkardı. Ve şuna benzer hata mesajları verdi:

System.Web.Compilation.CompilationException

error VBNC30248: CHANGEME


O yüzden eski versiyon (4.6.2) kurulararak sorun çözüldü.

  • nano /etc/apt/sources.list.d/mono-official-stable.list

Dosya düzenlendi ve içeriği şu şekilde değiştirildi:

deb https://download.mono-project.com/repo/ubuntu wheezy/snapshots/4.6.2 main


Ancak bu defa da libapache2-mod-mono paketi kurulamadı ve daha eski versiyon apache istendi. Bunun üzerine bu paket sona bırakıldı ve en son dosya şu şekilde düzenlendi:

nano /etc/apt/sources.list.d/mono-official-stable.list

deb https://download.mono-project.com/repo/ubuntu stable-xenial main


Denenmedi ancak eskisini silmeden bu satırı ilave etmek de çözüm olabilirdi belki.



Mono Tips

Create dll library with Mono:

For vb.net codes: vbnc, vbnc2
For c# classes: mcs

  • vbnc2 -target:library -imports:System.Text -r:bin/mbLib.dll -imports:System.Web -out:test.dll Ads.vb Custom.vb Common.vb DBTables.vb





wine

  • apt-get install wine

If cannot install in 64-bit OS, add i386 architecture then install.

  • dpkg --add-architecture i386

Install Latest wine:

  • apt-get install software-properties-common # for add-apt-repository command
  • add-apt-repository ppa:ubuntu-wine/ppa
  • apt-get update
  • apt-get install wine1.7


To Create 32-bit configuration if needed, on 64-bit wine installed:

WINEARCH=win32 WINEPREFIX=/home/m1/.wine32 winecfg


Wavelab 6, 64-bit wine içerisinde çalışmadı. Bu yöntemle 32-bit versiyon oluşturulunca, Wavelab 6 sorunsuz çalıştı. (2014-10)

Ayrıca program başlatırken bazı parametreleri atamak mümkün.

  • env LANG=tr_TR.UTF8 WINEPREFIX="/home/m1/.wine64" wine "/media/data/PROGRAM/VaV/VaV.exe"

Bu şekilde, bir programı, farklı klasörülere kurulan başka wine sürümlerini kullanarak çalıştırmak mümkün olabilmektedir.


Experiment: Install packages by selecting them

  • apt-cache show ubuntu-minimal
    Depends: adduser, apt, apt-utils, bzip2, console-setup, debconf, dhcp3-client, eject, gnupg, ifupdown, initramfs-tools, iproute, iputils-ping, kbd | kbd-compat, less, libc6-i686, locales, lsb-release, makedev, mawk, module-init-tools, net-tools, netbase, netcat | netcat-openbsd | netcat-traditional, ntpdate, passwd, procps, python, startup-tasks, sudo | sudo-ldap, sysklogd, system-services, tasksel, tzdata, ubuntu-keyring, udev, upstart, upstart-compat-sysv, upstart-logd, vim-tiny, whiptail

  • apt-cache depends lxde


https://askubuntu.com/questions/569521/avoid-installing-some-packages-from-metapackage

Firstly put the packages in a file:

  • apt-cache depends xubuntu-desktop | awk '$1 == "Depends:" {print $2}' > blacklist.txt

Then edit and leave only the packages you don't want to install:

  • nano blacklist.txt

Finally install all the packages except for the blacklisted ones:

  • apt-cache depends xubuntu-desktop | awk '$1 == "Depends:" {print $2}' | grep -vFf dont-want.txt | sudo xargs apt-get install



#mbirgin #ubuntu #freshinstall #defaultapps

m1gin 0

http://ubuntuhandbook.org/index.php/2019/04/nvidia-430-09-gtx-1650-support/

Nvidia GTX1650 ubuntu drivers

 

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt install nvidia-driver-440 nvidia-settings

Add to: